微信小程序开发者工具提示 没有找到可以构建的NPM包 或者 提示 XXXX/XXXX/XXXX.json 文件内容错误,请确认需要参与构建的 npm 在 miniprogramroot 目录,如果没有请按照一下方法进行解决,本内容适用于大多数错误。

安装 node.js 环境

下载 nodejs 安装包

官网下载:http://nodejs.cn/download/

腾讯下载:https://pc.qq.com/search.html#!keyword=nodejs

安装 npm 依赖

npm install

构建 nmp

使用 cmd 进入 app.js 所在小程序目录,并执行以下命令

npm init -y
// 参数 -y 表示对 npm 要求提供的信息,都自动按下回车键,表示接受默认值。

下载 miniprogram 依赖

npm i miniprogram-sm-crypto --production

以上完成后,进入微信小程序开发工具详情内勾选 使用 npm 依赖,

最后点击 微信小程序开发者工具->工具->构建npm ,到此就即可进行运行测试或二次开发了~